Biography.guide
Home › People › Programmer › Mark Crispin
Portrait of Mark Crispin

Mark Crispin

1956 – 2012

Father of IMAP protocol

Don't just read it — keep itBiographies to ownE-book · Audio · Video From $7 →

About Mark Crispin

Lived 1956 – 2012 (aged 56). Mark Crispin was an American programmer.

Mark Reed Crispin (July 19, 1956 in Camden, New Jersey – December 28, 2012 in Poulsbo, Washington ) is best known as the father of the Internet Message Access Protocol (IMAP), having invented it in 1985 during his time at the Stanford Knowledge Systems Laboratory. He is the author or co-author of numerous RFCs and was the principal author of UW IMAP, one of the reference implementations of the IMAP4rev1 protocol described in RFC 3501. He also designed the MIX mail storage format.

Crispin earned a B.S. in Technology and Society from Stevens Institute of Technology in 1977.

Career From 1977 to 1988, he was a Systems Programmer at Stanford University. He developed the first production PDP-10 96-bit leader ARPANET Network Control Program (NCP) for the WAITS operating system, and wrote or rewrote most of the WAITS ARPAnet protocol suite. Prior to that time most systems only supported the original 32-bit leader. During that time, he wrote the infamous RFC 748, the only document specifically marked in the RFC index with note date of issue; and a series of Telnet implementations for the Incompatible Timesharing System, WAITS, and TOPS-20 operating systems whose escape behavior was playfully immortalized by Guy Steele in the April 1984 Communications of the ACM as The Telnet Song.

In the early 1980s, shortly after becoming the Systems Programmer for the Stanford Computer Science Department's TOPS-20 system, he became interested in electronic mail software and systems; thereafter this became his primary focus. He became the principal developer of the TOPS-20 mailsystem, and reportedly was still running TOPS-20 systems at his residence in 2009. It was at Stanford, in the 1985–88 period, that IMAP was first developed.

From 1988 to 2008, he was a Software Engineer at the University of Washington, where much of the work in developing and popularizing IMAP and building what became UW IMAP was done. He forked UW IMAP into Panda IMAP in May 2008.

While working at UW, Mark was one of the creators of the simple and portable Unix email program Pine, launched in March 1992.

In 2005, he wrote RFC 4042, his second April Fools' Day RFC describing UTF-9 and UTF-18, encodings of Unicode optimized for the PDP-10.

In August 2008, Crispin joined Messaging Architects as a Senior Software Engineer. At Messaging Architects, he wrote an entirely new IMAP server based upon a distributed mail store, and extended the MIX format to support stubbing (via a mechanism called virtual mailboxes) and metadata.

Crispin is the creator of the TOPS-20 Panda distribution, a collection of available TOPS-20 software, which today is runnable on an emulator.

Death

On 19 November 2012, it was announced that Crispin was terminally ill and in hospice care, and he died on December 28, 2012.

Biography shop

Don’t just read it —
keep it.

Full-length biographies made to live with: read them, listen on the way to work, watch them tonight.

  • E-book
  • Audio
  • Video
Browse the shop — from $7

Instant download · yours to keep · every purchase keeps this site free

Important facts

Birth century
Occupation
Nationality
Education
Stevens Institute of Technology
Also known as
Mark Reed Crispin

People in Mark Crispin's life

Named in this biography and alive at the same time

Contemporaries

People whose lives overlapped Mark Crispin's

Frequently asked questions

Who was Mark Crispin?

father of IMAP protocol

When was Mark Crispin born?

Mark Crispin was born on 19 July 1956 in Camden.

When did Mark Crispin die?

Mark Crispin died on 28 December 2012 in Poulsbo.

What was Mark Crispin's occupation?

Mark Crispin was a programmer.

What nationality was Mark Crispin?

Mark Crispin was American.

Sources & further reading

· Wikipedia: Mark Crispin

· Wikidata: Q6767198

· DBpedia: Mark Crispin

Cite this page

APA: Biography.guide. (2026). Mark Crispin. https://biography.guide/mark-crispin/

MLA: "Mark Crispin." Biography.guide, https://biography.guide/mark-crispin/.

Chicago: "Mark Crispin." Biography.guide. https://biography.guide/mark-crispin/.

Data last updated: 2026-09-20 · Spot an error? Report a correction.

Page generated 2026-09-27 05:13 UTC