About Dave Täht
Lived 1965 – 2025 (aged 59). Dave Täht was an American internet activist and programmer.
Dave Täht (August 11, 1965 – April 1, 2025) was an American network engineer, musician, lecturer, asteroid exploration advocate and Internet activist. He was the chief executive officer of TekLibre.
Activity Täht co-founded the Bufferbloat Project with Jim Gettys, ran the CeroWrt and Make-Wifi-Fast sub-projects, and refereed the bufferbloat related mailing lists and related research activities.
With a long running goal of one day building an internet with low latency and jitter that "you could plug your piano into the wall and play with a drummer across town", he explained how queues across the internet (and wifi) really work, lecturing at MIT, Stanford, and other internet institutions such as APNIC.
In the early stages of the Bufferbloat project he helped prove that applying advanced AQM and Fair Queuing techniques like (FQ-CoDel) to network packet flows would break essential assumptions in existing low priority congestion controls such as bittorrent and LEDBAT and further, that it did not matter.
His CeroWrt project showed that advanced algorithms like CoDel, FQ-CoDel, DOCSIS-PIE and Cake were effective at reducing network latency, at no cost in throughput not only at low bandwidths but scaled to 10s of GB/s and could be implemented on inexpensive hardware. CeroWrt project members also helped make OpenWrt ready for IPv6 Launch Day, and pushed all the innovations back into open source.
His successor Make-Wifi-Fast project solved the WiFi performance anomaly by extending the FQ-Codel algorithm to work on multiple WiFi chips in Linux, reducing latency under load by up to a factor of 50.
FQ-CoDel has since become the default network queuing algorithm for Ethernet and Wi-Fi in most Linux distributions, and on iOS, and macOS. It is also widely used in packet shapers. Comcast also successfully rolled out the DOCSIS-PIE AQM during the COVID crisis with observed 8-16x reductions in network latency under load across the millions of user devices tested.
In order to complete the make-wifi-fast project, by co-authoring an FCC filing and co-ordinating a worldwide protest with Vint Cerf, and many other early Internet pioneers, Taht successfully fought proposed FCC rules that would prohibit the installation of 3rd party firmware on home routers.
He had been intensely critical of the academic network research community, extolling open access, open source code and the value of negative and repeatable results.
As one of the instigators of the IETF AQM and Packet Scheduling working group, he is the co-author of RFC8290, and a contributor to RFC8289 (CODEL), RFC7567, RFC8034, RFC7928, RFC7806, and RFC8033. He also made contributions to the DOCSIS 3.1 standard.
He was a filksinger, often performing songs like "It GPLs me", and "One First Landing" at various computer and science fiction conventions.
He served on the Commons Conservancy board of directors.
Täht died on April 1, 2025, at the age of 59. News of his death was shared in a post by the LibreQoS project.
Don’t just read it —
keep it.
Full-length biographies made to live with: read them, listen on the way to work, watch them tonight.
- E-book
- Audio
- Video
Instant download · yours to keep · every purchase keeps this site free
Important facts
People in Dave Täht's life
Named in this biography and alive at the same time
Contemporaries
People whose lives overlapped Dave Täht's
Frequently asked questions
Who was Dave Täht?
American network engineer and Internet activist (1965-2025)
When was Dave Täht born?
Dave Täht was born on 11 August 1965 in Ocean City.
When did Dave Täht die?
Dave Täht died on 1 April 2025.
What was Dave Täht's occupation?
Dave Täht was an internet activist and programmer.
What nationality was Dave Täht?
Dave Täht was American.
Sources & further reading
Cite this page
APA: Biography.guide. (2026). Dave Täht. https://biography.guide/dave-taht/
MLA: "Dave Täht." Biography.guide, https://biography.guide/dave-taht/.
Chicago: "Dave Täht." Biography.guide. https://biography.guide/dave-taht/.
Data last updated: 2026-09-20 · Spot an error? Report a correction.
Page generated 2026-09-27 05:17 UTC