Paul Mockapetris
American computer scientist and Internet pioneer
About Paul Mockapetris
Born 1948. Paul Mockapetris is an American computer scientist, patent inventor, programmer and scientist, known for Domain Name System.
Education Mockapetris graduated from the Boston Latin School in 1966 , received his bachelor's degrees in physics and electrical engineering from the Massachusetts Institute of Technology in 1971 and his doctorate in information and computer science from the University of California, Irvine in 1982.
Career In 1983, he proposed a Domain Name System architecture in RFC 882 and RFC 883. He had recognized the problem in the early Internet (then ARPAnet) of holding name to address translations in a single table on the hosts file of an operating system. Instead he proposed a distributed and dynamic DNS database: essentially DNS as it exists today. 2002 Distinguished Alumnus award from the University of California, Irvine 2003 IEEE Internet Award for his contributions to DNS 2004 ACM Fellow, for contributions to the Internet, including the development of domain and email protocols. 2005 ACM SIGCOMM Award for lifetime contribution to the field of communication networks in recognition of his foundational work in designing, developing and deploying the Domain Name System, and his sustained leadership in overall Internet architecture development 2006 ACM SIGCOMM Test of Time Paper Award for co-authoring paper "Development of the Domain Name System" 2006 National Academy of Engineering Member 2012 inducted by the Internet Society into the Internet Hall of Fame as an "innovator" 2013 Honoris Causa (honorary degree) by Miguel Hernández University (Alicante, Spain) 2019 ACM Software System Award
Requests for Comments (RFCs) RFC 1035 - Domain Names - Implementation and Specification, November 1987 RFC 1034 - Domain Names - Concepts and Facilities, November 1987 RFC 973 - Domain System Changes and Observations, January 1986 (obsoleted by 1034 and 1035) RFC 883 - Domain Names - Implementation and Specification, November 1983 (updated by 973, obsoleted by 1034 and 1035) RFC 882 - Domain Names - Concepts and Facilities, November 1983 (updated by 973, obsoleted by 1034 and 1035)
Don’t just read it —
keep it.
Full-length biographies made to live with: read them, listen on the way to work, watch them tonight.
- E-book
- Audio
- Video
Instant download · yours to keep · every purchase keeps this site free
Important facts
People in Paul Mockapetris's life
Named in this biography and alive at the same time
Contemporaries
People whose lives overlapped Paul Mockapetris's
Frequently asked questions
Who is Paul Mockapetris?
American computer scientist and Internet pioneer
When was Paul Mockapetris born?
Paul Mockapetris was born on 18 November 1948 in Boston.
What is Paul Mockapetris's occupation?
Paul Mockapetris is a computer scientist, patent inventor, programmer and scientist.
What is Paul Mockapetris known for?
Paul Mockapetris is known for Domain Name System.
What nationality is Paul Mockapetris?
Paul Mockapetris is American.
Sources & further reading
Cite this page
APA: Biography.guide. (2026). Paul Mockapetris. https://biography.guide/paul-mockapetris/
MLA: "Paul Mockapetris." Biography.guide, https://biography.guide/paul-mockapetris/.
Chicago: "Paul Mockapetris." Biography.guide. https://biography.guide/paul-mockapetris/.
Data last updated: 2026-09-20 · Spot an error? Report a correction.
Page generated 2026-09-27 05:17 UTC