About Tim Bray
Born 1955. Tim Bray is a Canadian computer scientist and blogger, known for Web standards and XML.
Education and early life Bray was born on June 21, 1955 in Alberta, Canada, where his father worked for the Dominion Experimental Farm Service in Fort Vermilion. He grew up in Beirut, Lebanon, and returned to Canada to attend school at the University of Guelph in Guelph, Ontario. He graduated in 1981 with a Bachelor of Science, double majoring in mathematics and computer Science. In 2009, he would return to Guelph to receive an honorary doctorate. Tim described his switch of focus from math to computer science this way: "In math I'd worked like a dog for my Cs, but in CS I worked much less for As—and learned that you got paid well for doing it."
Career Bray joined Digital Equipment Corporation (DEC) in Toronto as a software specialist. In 1983, Bray left DEC for Microtel Pacific Research. He joined the New Oxford English Dictionary (OED) project at the University of Waterloo in 1987 as its manager. It was during this time Bray worked with SGML, a technology that would later become central to both Open Text Corporation and his XML and Atom standardization work. Bray was director of Web Technologies at Sun Microsystems from early 2004 to early 2010. He left Google in March 2014, unwilling to relocate to Silicon Valley from Vancouver. He started working for Amazon Web Services (AWS) in December 2014. Bray left AWS in May 2020, after being dismayed by Amazon's treatment of whistleblowers who had raised concerns over the safety of warehouse workers in relation to the COVID-19 pandemic. Bray had held the vice president rank, stating on his blog that "VPs shouldn't go publicly rogue", and had much praise for AWS, yet he wasn't pleased about his co-workers being fired. a consulting practice in the field of web and publishing technology. He was contracted by Netscape in 1999, along with Ramanathan V. Guha, for Xml.com which proposed a means to improve web client user experience and web server system performance via a Transform-Aggregate-send XML-Interact architecture—this proposed system is very similar to the Ajax paradigm, popularized around 2005.
W3C TAG Between 2001 and 2004 he served as a Tim Berners-Lee appointee to the W3C Technical Architecture Group.
Atom Until October 2007, Bray was co-chair, with Paul Hoffman, of the Atom-focused Atompub Working Group of the Internet Engineering Task Force. Atom is a web syndication format developed to address perceived deficiencies with the RSS 2.0 format.
JSON Bray worked with the IETF JSON Working Group in 2013 and 2014, serving as editor of RFC 7159, a specification of the JSON Data Interchange Format which revised RFC 4627 and highlighted interoperability best practices, released in March 2014. He also edited RFC 8259, a further revision of JSON.
Software Bray has written software applications, including Bonnie which was the inspiration for Bonnie++, a Unix file system benchmarking tool; Lark, the first XML processor; and APE, the Atom Protocol Exerciser.
Environmentalism
Starting in 2018, Bray became visible as an environmentalist in the context of the Trans Mountain Pipeline dispute. On April 18, 2018, he was arrested for contempt of court at a demonstration at the Trans Mountain site in Burnaby, Canada. He also participated in an open letter from business leaders to the British Columbia government and was subsequently a public voice against the project. In 2019, Bray was the only VP-level Amazon employee to sign a letter to Amazon shareholders calling for a stop to Amazon Web Services' support for oil extraction.
In 2024, Bray co-edited a book titled Standing On High Ground, a collection of personal stories of individuals who were arrested while protesting the Trans Mountain pipeline expansion.
Don’t just read it —
keep it.
Full-length biographies made to live with: read them, listen on the way to work, watch them tonight.
- E-book
- Audio
- Video
Instant download · yours to keep · every purchase keeps this site free
Important facts
People in Tim Bray's life
Named in this biography and alive at the same time
Contemporaries
People whose lives overlapped Tim Bray's
Frequently asked questions
Who is Tim Bray?
Canadian software developer (b. 1955)
When was Tim Bray born?
Tim Bray was born on 21 June 1955 in Canada.
What is Tim Bray's occupation?
Tim Bray is a computer scientist and blogger.
What is Tim Bray known for?
Tim Bray is known for Web standards and XML.
What nationality is Tim Bray?
Tim Bray is Canadian.
Sources & further reading
Cite this page
APA: Biography.guide. (2026). Tim Bray. https://biography.guide/tim-bray/
MLA: "Tim Bray." Biography.guide, https://biography.guide/tim-bray/.
Chicago: "Tim Bray." Biography.guide. https://biography.guide/tim-bray/.
Data last updated: 2026-09-20 · Spot an error? Report a correction.
Page generated 2026-09-27 05:29 UTC